Skip to main content
Skip table of contents

Eleveo Documentation

Important changes.

User documentation is freely available → Go to help.eleveo.com

Admin documentation is available via secure login. Go to the http://portal.eleveo.com and click a link to the documentation to access the administrator documentation.

Important Information – Version 9 is Cloud Only

Version 9.4 supports On-Premise, Cloud-Only and Hybrid deployment types.

  • Hybrid installations – For some installation types Eleveo supports Hybrid deployments. In a hybrid setup, your recorders remain on-premise, but your media records are uploaded to the Eleveo Cloud for playback and review.

  • On-premise installation – Version 9.4 is fully supported for on-premise installations.

  • For cloud installations only – Partners and customers no longer need to manage and install the solution.

Contact your local Eleveo representative or an Eleveo sales representative at sales@eleveo.com for more information.

Supported and Unsupported Versions

Upgrade to the most recent version to take advantage of new features!

Product and Version

Current Support Level

Release

LOD

EOM/EOS

Notes

Elevēo 9.3

Full Support

December, 2023

 – 

 – 

Upgrade recommended.

Elevēo 9.2

Superseded by V 9.3

October, 2023

 – 

 – 

Upgrade recommended.

Elevēo 9.1

Superseded by V 9.2

July, 2023

 – 

 – 

Upgrade recommended.

Elevēo 9.0

Superseded by V 9.1

April, 2023

 – 

 – 

Upgrade to take advantage of bug fixes, enhanced functionality and improved stability.

Elevēo 8.3

Full Support

January, 2023

April, 2024

June, 2024

This is an F2M version.

Elevēo 8.2

Superseded by V 8.3

August, 2022

April, 2024

May, 2024

This is an F2M version.

Elevēo 8.1

Superseded by V 8.2

May, 2022

April, 2024

May, 2024

This is an F2M version.

Elevēo 7.1 and Elevēo 7.0

Full Support

January, 2022

April, 2024

June, 2024

These are LTS versions.

End of Life Update - LTS Version

Version 7.1 - EOS June 2024

Version 7.1 will reach its end of support date (EOS) in June 2024. The last maintenance version will be released at that time. Version 9.4 is a replacement for version 7.1.

To support our customers during this transition period, Eleveo will offer limited support for version 7.1 until June 2025 with the following important limitations:

No regular maintenance patches will be provided
Patching of critical application or security issues will be performed on a case-by-case basis
The operating system will no longer be patched as the vendor discontinues support
Eleveo may decide to release ad hoc patches for third-party component

Version 9.4 - Anticipated Q1 2024

This version will support deployment on-premise, in the cloud, or in hybrid environments.

This version will be equipped with Rocky Linux 8 (supported by the vendor until 2029) and data will be stored in a separate storage space (partition). Later in 2024, we will be releasing a Long-Term Support (LTS) version that can be easily upgraded from version 9.4 and will be supported for a standard period of two years. The hardware specifications of 9.4 and the future LTS version will be very similar. Version 9.4 will completely replace version 7.

Archive - Login Required

Versions that have reached End of Support. All Customers are advised to upgrade to the latest supported release.

Product and Version

Current Support Level

Release

LOD

EOM/EOS

Notes

Version 6.6

Not Supported

October, 2019

December, 2020

December, 2021

Upgrade recommended.

Version 6.5

Not Supported

July, 2019

October, 2019

Not Supported

Upgrade recommended.

Version 6.4

Not Supported

August, 2018

September, 2019

Not Supported

Upgrade recommended.

Version 6.3

Not Supported

April 2018

August, 2018

Not Supported

Upgrade recommended.

Version 6.1

Not Supported

June, 2017

April, 2018

Not Supported

Upgrade recommended.

Version 6.0

Not Supported

December, 2016

June, 2017

Not Supported

Upgrade recommended.

Version 5.8

Not Supported

Aug 12, 2016

March 09, 2017

July 31, 2018 / July 31, 2019

Reached End of Support. 

Version 5.6

Not Supported

Jul 9, 2015

December 14, 2015

July 31, 2017 / July 31, 2018

Reached End of Support. 

LOD = Last Order Date

EOS = End of Support

EOM = End of Maintenance

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.